Notice: Potential Interruption of Instagram publishing

Incident Report for Facelift

Resolved

The technical problems caused by Meta affecting Instagram publishing have been resolved. This incident was caused by a platform-side outage on Meta's infrastructure and was outside of Facelift's control.

All Instagram publishing functionality is now fully restored.

We apologize for any inconvenience this may have caused and thank you for your patience.
Posted May 27, 2026 - 08:44 CEST

Identified

We are aware that some users may experience limited availability of Instagram post publishing due to ongoing technical issues on Meta's platform. Posts are displayed as 'failed', but are actually published successfully later. Our team is in direct contact with Meta and working towards a prompt resolution to ensure the full restoration of Instagram Publishing.
Posted May 26, 2026 - 11:43 CEST
This incident affected: Social Networks (Instagram).